CVE-2023-27596

High

Description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, OpenSIPS crashes when a malformed SDP body is sent multiple times to an OpenSIPS configuration that makes use of the `stream_process` function. This issue was discovered during coverage guided fuzzing of the function `codec_delete_except_re`. By abusing this vulnerability, an attacker is able to crash the server. It affects configurations containing functions that rely on the affected code, such as the function `codec_delete_except_re`. This issue has been fixed in version 3.1.8 and 3.2.5.

SeverityHigh
CVSS7.5
Exploit probability—
ProductOpensips
PublishedMar 15, 2023
First seenMar 15, 2023

How to fix

Update
  • opensips opensips3.1.8, 3.2.5 or later

Affected products

ProductAffected versionsFixed in
opensips opensipsv < 3.1.8, 3.2.0 ≤ v < 3.2.53.1.8, 3.2.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.