CVE-2023-28095

High

Description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.1.7 and 3.2.4 have a potential issue in `msg_translator.c:2628` which might lead to a server crash. This issue was found while fuzzing the function `build_res_buf_from_sip_req` but could not be reproduced against a running instance of OpenSIPS. This issue could not be exploited against a running instance of OpenSIPS since no public function was found to make use of this vulnerable code. Even in the case of exploitation through unknown vectors, it is highly unlikely that this issue would lead to anything other than Denial of Service. This issue has been fixed in versions 3.1.7 and 3.2.4.

SeverityHigh
CVSS7.5
Exploit probability—
ProductOpensips
PublishedMar 15, 2023
First seenMar 15, 2023

How to fix

Update
  • opensips opensips3.1.7, 3.2.4 or later

Affected products

ProductAffected versionsFixed in
opensips opensipsv < 3.1.7, 3.2.0 ≤ v < 3.2.43.1.7, 3.2.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-28095 · Opensips · Dark Radar