CVE-2023-28104
Description
`silverstripe/graphql` serves Silverstripe data as GraphQL representations. In versions 4.2.2 and 4.1.1, an attacker could use a specially crafted graphql query to execute a denial of service attack against a website which has a publicly exposed graphql endpoint. This mostly affects websites with particularly large/complex graphql schemas. Users should upgrade to `silverstripe/graphql` 4.2.3 or 4.1.2 to remedy the vulnerability.
How to fix
- silverstripe/graphql4.1.2, 4.2.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| silverstripe graphql | 4.1.1, 4.2.2 | — |
| silverstripe/graphqlPackagist | 4.1.1 ≤ v < 4.1.2, 4.2.2 ≤ v < 4.2.3 | 4.1.2, 4.2.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.