CVE-2023-28115

Critical

Description

Snappy is a PHP library allowing thumbnail, snapshot or PDF generation from a url or a html page. Prior to version 1.4.2, Snappy is vulnerable to PHAR deserialization due to a lack of checking on the protocol before passing it into the `file_exists()` function. If an attacker can upload files of any type to the server he can pass in the phar:// protocol to unserialize the uploaded file and instantiate arbitrary PHP objects. This can lead to remote code execution especially when snappy is used with frameworks with documented POP chains like Laravel/Symfony vulnerable developer code. If a user can control the output file from the `generateFromHtml()` function, it will invoke deserialization. This vulnerability is capable of remote code execution if Snappy is used with frameworks or developer code with vulnerable POP chains. It has been fixed in version 1.4.2.

SeverityCritical
CVSS9.8
Exploit probability—
ProductKnplabs Snappy
PublishedMar 17, 2023
First seenMar 17, 2023

How to fix

Update
  • knplabs snappy1.4.2 or later
  • knplabs/knp-snappy1.4.2 or later

Affected products

ProductAffected versionsFixed in
knplabs snappyv < 1.4.21.4.2
knplabs/knp-snappyPackagistv < 1.4.21.4.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-28115 · Knplabs Snappy · Dark Radar