CVE-2023-28447
Description
Smarty is a template engine for PHP. In affected versions smarty did not properly escape javascript code. An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user. Users are advised to upgrade to either version 3.1.48 or to 4.3.1 to resolve this issue. There are no known workarounds for this vulnerability.
How to fix
- smarty smarty3.1.48, 4.3.1 or later
- smarty/smarty4.3.1, 3.1.48 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| smarty smarty | v < 3.1.48, 4.0.0 ≤ v < 4.3.1 | 3.1.48, 4.3.1 |
| fedoraproject fedora | 36, 37, 38 | — |
| smarty/smartyPackagist | 4.0.0 ≤ v < 4.3.1, v < 3.1.48 | 4.3.1, 3.1.48 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.