CVE-2023-28835

Low

Description

Nextcloud server is an open source home cloud implementation. In affected versions the generated fallback password when creating a share was using a weak complexity random number generator, so when the sharer did not change it the password could be guessable to an attacker willing to brute force it. It is recommended that the Nextcloud Server is upgraded to 24.0.10 or 25.0.4. This issue only affects users who do not have a password policy enabled, so enabling a password policy is an effective mitigation for users unable to upgrade.

SeverityLow
CVSS3.5
Exploit probability—
ProductNextcloud Server
PublishedMar 30, 2023
First seenMar 30, 2023
Weakness typeCWE-338CWE-338

How to fix

Update
  • nextcloud nextcloud_server23.0.14, 24.0.10, 25.0.4 or later

Affected products

ProductAffected versionsFixed in
nextcloud nextcloud_server23.0.0 ≤ v < 23.0.14, 24.0.0 ≤ v < 24.0.10, 25.0.0 ≤ v < 25.0.423.0.14, 24.0.10, 25.0.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.