CVE-2023-28836

Medium

Description

Wagtail is an open source content management system built on Django. Starting in version 1.5 and prior to versions 4.1.4 and 4.2.2, a stored cross-site scripting (XSS) vulnerability exists on ModelAdmin views within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft pages and documents that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, and only affects sites with ModelAdmin enabled. For page, the vulnerability is in the "Choose a parent page" ModelAdmin view (`ChooseParentView`), available when managing pages via ModelAdmin. For documents, the vulnerability is in the ModelAdmin Inspect view (`InspectView`) when displaying document fields. Patched versions have been released as Wagtail 4.1.4 and Wagtail 4.2.2. Site owners who are unable to upgrade to the new versions can disable or override the corresponding functionality.

SeverityMedium
CVSS6.4
Exploit probability—
ProductTorchbox Wagtail
PublishedApr 3, 2023
First seenApr 3, 2023

How to fix

Update
  • torchbox wagtail4.1.4, 4.2.2 or later
  • wagtail4.1.4, 4.2.2 or later

Affected products

ProductAffected versionsFixed in
torchbox wagtail1.5 ≤ v < 4.1.4, 4.2 ≤ v < 4.2.24.1.4, 4.2.2
wagtailPyPI1.5 ≤ v < 4.1.4, 4.2 ≤ v < 4.2.24.1.4, 4.2.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.