CVE-2023-29014

Medium

Description

The Goobi viewer is a web application that allows digitised material to be displayed in a web browser. A reflected cross-site scripting vulnerability has been identified in Goobi viewer core prior to version 23.03 when evaluating the LOGID parameter. An attacker could trick a user into following a specially crafted link to a Goobi viewer installation, resulting in the execution of malicious script code in the user's browser. The vulnerability has been fixed in version 23.03.

SeverityMedium
CVSS6.1
Exploit probability—
ProductIntranda Goobi Viewer Core
PublishedApr 6, 2023
First seenApr 6, 2023

How to fix

Update
  • intranda goobi_viewer_core23.03 or later
  • io.goobi.viewer:viewer-core23.03 or later

Affected products

ProductAffected versionsFixed in
intranda goobi_viewer_corev < 23.0323.03
io.goobi.viewer:viewer-coreMavenv < 23.0323.03

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.