CVE-2023-29216
Description
In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.
How to fix
- org.apache.linkis:linkis-datasource1.3.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache linkis | v ≤ 1.3.1 | — |
| org.apache.linkis:linkis-datasourceMaven | v < 1.3.2 | 1.3.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.