CVE-2023-30362

High

Description

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.

SeverityHigh
CVSS7.5
Exploit probability—
ProductLibcoap
PublishedJun 23, 2023
First seenJun 23, 2023

How to fix

Update
  • libcoap libcoap4.3.1-120-ge242200 or later

Affected products

ProductAffected versionsFixed in
libcoap libcoapv < 4.3.1-120-ge2422004.3.1-120-ge242200

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-30362 · Libcoap · Dark Radar