CVE-2023-30428

High

Description

Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar Broker's Rest Producer allows authenticated user with a custom HTTP header to produce a message to any topic using the broker's admin role. This issue affects Apache Pulsar Brokers: from 2.9.0 through 2.9.5, from 2.10.0 before 2.10.4, 2.11.0. The vulnerability is exploitable when an attacker can connect directly to the Pulsar Broker. If an attacker is connecting through the Pulsar Proxy, there is no known way to exploit this authorization vulnerability. There are two known risks for affected users. First, an attacker could produce garbage messages to any topic in the cluster. Second, an attacker could produce messages to the topic level policies topic for other tenants and influence topic settings that could lead to exfiltration and/or deletion of messages for other tenants. 2.8 Pulsar Broker users and earlier are unaffected. 2.9 Pulsar Broker users should upgrade to one of the patched versions. 2.10 Pulsar Broker users should upgrade to at least 2.10.4. 2.11 Pulsar Broker users should upgrade to at least 2.11.1. 3.0 Pulsar Broker users are unaffected.

SeverityHigh
CVSS8.2
Exploit probability—
ProductApache Pulsar
PublishedJul 12, 2023
First seenJul 12, 2023

How to fix

Update
  • apache pulsar2.10.4 or later
  • org.apache.pulsar:pulsar-broker2.10.4, 2.11.1 or later

Affected products

ProductAffected versionsFixed in
apache pulsar2.9.0 ≤ v ≤ 2.9.5, 2.10.0 ≤ v < 2.10.4, 2.11.02.10.4
org.apache.pulsar:pulsar-brokerMaven2.9.0 ≤ v < 2.10.4, 2.11.0 ≤ v < 2.11.12.10.4, 2.11.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.