CVE-2023-30429
Description
Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar. This issue affects Apache Pulsar: before 2.10.4, and 2.11.0. When a client connects to the Pulsar Function Worker via the Pulsar Proxy where the Pulsar Proxy uses mTLS authentication to authenticate with the Pulsar Function Worker, the Pulsar Function Worker incorrectly performs authorization by using the Proxy's role for authorization instead of the client's role, which can lead to privilege escalation, especially if the proxy is configured with a superuser role. The recommended mitigation for impacted users is to upgrade the Pulsar Function Worker to a patched version. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.4. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.1. 3.0 Pulsar Function Worker users are unaffected. Any users running the Pulsar Function Worker for 2.9.* and earlier should upgrade to one of the above patched versions.
How to fix
- apache pulsar2.10.4 or later
- org.apache.pulsar:pulsar2.10.4, 2.11.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache pulsar | v < 2.10.4, 2.11.0 | 2.10.4 |
| org.apache.pulsar:pulsarMaven | v < 2.10.4, 2.11.0 ≤ v < 2.11.1 | 2.10.4, 2.11.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.