CVE-2023-30541

Medium

Description

OpenZeppelin Contracts is a library for secure smart contract development. A function in the implementation contract may be inaccessible if its selector clashes with one of the proxy's own selectors. Specifically, if the clashing function has a different signature with incompatible ABI encoding, the proxy could revert while attempting to decode the arguments from calldata. The probability of an accidental clash is negligible, but one could be caused deliberately and could cause a reduction in availability. The issue has been fixed in version 4.8.3. As a workaround if a function appears to be inaccessible for this reason, it may be possible to craft the calldata such that ABI decoding does not fail at the proxy and the function is properly proxied through.

SeverityMedium
CVSS5.3
Exploit probability—
ProductOpenzeppelin Contracts
PublishedApr 17, 2023
First seenApr 17, 2023
Weakness typeCWE-436CWE-436

How to fix

Update
  • openzeppelin contracts4.8.3 or later
  • openzeppelin contracts_upgradeable4.8.3 or later
  • @openzeppelin/contracts4.8.3 or later
  • @openzeppelin/contracts-upgradeable4.8.3 or later

Affected products

ProductAffected versionsFixed in
openzeppelin contracts3.2.0 ≤ v < 4.8.34.8.3
openzeppelin contracts_upgradeable3.2.0 ≤ v < 4.8.34.8.3
@openzeppelin/contractsnpm3.2.0 ≤ v < 4.8.34.8.3
@openzeppelin/contracts-upgradeablenpm3.2.0 ≤ v < 4.8.34.8.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-30541 · Openzeppelin Contracts · Dark Radar