CVE-2023-30614

High

Description

Pay is a payments engine for Ruby on Rails 6.0 and higher. In versions prior to 6.3.2 a payments info page of Pay is susceptible to reflected Cross-site scripting. An attacker could create a working URL that renders a javascript link to a user on a Rails application that integrates Pay. This URL could be distributed via email to specifically target certain individuals. If the targeted application contains a functionality to submit user-generated content (such as comments) the attacker could even distribute the URL using that functionality. This has been patched in version 6.3.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.

SeverityHigh
CVSS7.1
Exploit probability—
ProductPay
PublishedApr 19, 2023
First seenApr 19, 2023

How to fix

Update
  • pay_project pay6.3.2 or later

Affected products

ProductAffected versionsFixed in
pay_project payv < 6.3.26.3.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.