CVE-2023-30852

Medium

Description

Pimcore is an open source data and experience management platform. Prior to version 10.5.21, the `/admin/misc/script-proxy` API endpoint that is accessible by an authenticated administrator user is vulnerable to arbitrary JavaScript and CSS file read via the `scriptPath` and `scripts` parameters. The `scriptPath` parameter is not sanitized properly and is vulnerable to path traversal attack. Any JavaScript/CSS file from the application server can be read by specifying sufficient number of `../` patterns to go out from the application webroot followed by path of the folder where the file is located in the "scriptPath" parameter and the file name in the "scripts" parameter. The JavaScript file is successfully read only if the web application has read access to it. Users should update to version 10.5.21 to receive a patch or, as a workaround, apply the patch manual.

SeverityMedium
CVSS4.4
Exploit probability—
ProductPimcore
PublishedApr 27, 2023
First seenApr 27, 2023

How to fix

Update
  • pimcore pimcore10.5.21 or later
  • pimcore/pimcore10.5.21 or later

Affected products

ProductAffected versionsFixed in
pimcore pimcorev < 10.5.2110.5.21
pimcore/pimcorePackagistv < 10.5.2110.5.21

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.