CVE-2023-31007
Description
Improper Authentication vulnerability in Apache Software Foundation Apache Pulsar Broker allows a client to stay connected to a broker after authentication data expires if the client connected through the Pulsar Proxy when the broker is configured with authenticateOriginalAuthData=false or if a client connects directly to a broker with a specially crafted connect command when the broker is configured with authenticateOriginalAuthData=false. This issue affects Apache Pulsar: through 2.9.4, from 2.10.0 through 2.10.3, 2.11.0. 2.9 Pulsar Broker users should upgrade to at least 2.9.5. 2.10 Pulsar Broker users should upgrade to at least 2.10.4. 2.11 Pulsar Broker users should upgrade to at least 2.11.1. 3.0 Pulsar Broker users are unaffected. Any users running the Pulsar Broker for 2.8.* and earlier should upgrade to one of the above patched versions.
How to fix
- apache pulsar2.9.5 or later
- org.apache.pulsar:pulsar-broker2.10.4, 2.11.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache pulsar | v < 2.9.5, 2.10.0 ≤ v ≤ 2.10.3, 2.11.0 | 2.9.5 |
| org.apache.pulsar:pulsar-brokerMaven | 2.9.0 ≤ v < 2.10.4, 2.11.0 ≤ v < 2.11.1 | 2.10.4, 2.11.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.