CVE-2023-31043

High

Description

EnterpriseDB EDB Postgres Advanced Server (EPAS) before 14.6.0 logs unredacted passwords in situations where optional parameters are used with CREATE/ALTER USER/GROUP/ROLE, and redacting was configured with edb_filter_log.redact_password_commands. The fixed versions are 10.23.33, 11.18.29, 12.13.17, 13.9.13, and 14.6.0.

SeverityHigh
CVSS7.5
Exploit probability—
ProductEnterprisedb Postgres Advanced Server
PublishedApr 23, 2023
First seenApr 23, 2023
Weakness typeCWE-521CWE-521

How to fix

Update
  • enterprisedb postgres_advanced_server10.23.33, 11.18.29, 12.13.17, 13.9.13, 14.6.0 or later

Affected products

ProductAffected versionsFixed in
enterprisedb postgres_advanced_serverv < 10.23.33, 11.1.7 ≤ v < 11.18.29, 12.1.2 ≤ v < 12.13.17, 13.1.4 ≤ v < 13.9.13, 14.1.0 ≤ v < 14.6.010.23.33, 11.18.29, 12.13.17, 13.9.13, 14.6.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.