CVE-2023-31056

Critical

Description

CloverDX before 5.17.3 writes passwords to the audit log in certain situations, if the audit log is enabled and single sign-on is not employed. The fixed versions are 5.15.4, 5.16.2, 5.17.3, and 6.0.x.

SeverityCritical
CVSS9.1
Exploit probability—
ProductCloverdx
PublishedApr 24, 2023
First seenApr 24, 2023
Weakness typeCWE-532CWE-532

How to fix

Update
  • cloverdx cloverdx5.17.3 or later

Affected products

ProductAffected versionsFixed in
cloverdx cloverdx5.14.0 ≤ v ≤ 5.14.3, 5.15.0 ≤ v ≤ 5.15.3, 5.17.0 ≤ v < 5.17.3, 5.16.0, 5.16.15.17.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.