CVE-2023-31062

Critical

Description

Improper Privilege Management Vulnerabilities in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.2.0 through 1.6.0.  When the attacker has access to a valid (but unprivileged) account, the exploit can be executed using Burp Suite by sending a login request and following it with a subsequent HTTP request using the returned cookie. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 to solve it.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Inlong
PublishedMay 22, 2023
First seenMay 22, 2023

How to fix

Update
  • org.apache.inlong:manager-pojo1.7.0 or later
  • org.apache.inlong:manager-dao1.7.0 or later
  • org.apache.inlong:manager-service1.7.0 or later
  • org.apache.inlong:manager-web1.7.0 or later

Affected products

ProductAffected versionsFixed in
apache inlong1.2.0 ≤ v ≤ 1.6.0—
org.apache.inlong:manager-pojoMaven1.2.0 ≤ v < 1.7.01.7.0
org.apache.inlong:manager-daoMaven1.2.0 ≤ v < 1.7.01.7.0
org.apache.inlong:manager-serviceMaven1.2.0 ≤ v < 1.7.01.7.0
org.apache.inlong:manager-webMaven1.2.0 ≤ v < 1.7.01.7.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.