CVE-2023-31065

Critical

Description

Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0.  An old session can be used by an attacker even after the user has been deleted or the password has been changed. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 , https://github.com/apache/inlong/pull/7884 https://github.com/apache/inlong/pull/7884 to solve it.

SeverityCritical
CVSS9.1
Exploit probability—
ProductApache Inlong
PublishedMay 22, 2023
First seenMay 22, 2023
Weakness typeCWE-613CWE-613

How to fix

Update
  • org.apache.inlong:manager-pojo1.7.0 or later
  • org.apache.inlong:manager-dao1.7.0 or later
  • org.apache.inlong:manager-web1.7.0 or later
  • org.apache.inlong:manager-service1.7.0 or later

Affected products

ProductAffected versionsFixed in
apache inlong1.4.0 ≤ v ≤ 1.6.0—
org.apache.inlong:manager-pojoMaven1.4.0 ≤ v < 1.7.01.7.0
org.apache.inlong:manager-daoMaven1.4.0 ≤ v < 1.7.01.7.0
org.apache.inlong:manager-webMaven1.4.0 ≤ v < 1.7.01.7.0
org.apache.inlong:manager-serviceMaven1.4.0 ≤ v < 1.7.01.7.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.