CVE-2023-31131

High

Description

Greenplum Database (GPDB) is an open source data warehouse based on PostgreSQL. In versions prior to 6.22.3 Greenplum Database used an unsafe methods to extract tar files within GPPKGs. greenplum-db is vulnerable to path traversal leading to arbitrary file writes. An attacker can use this vulnerability to overwrite data or system files potentially leading to crash or malfunction of the system. Any files which are accessible to the running process are at risk. All users are requested to upgrade to Greenplum Database version 6.23.2 or higher. There are no known workarounds for this vulnerability.

SeverityHigh
CVSS7.4
Exploit probability—
ProductVmware Greenplum Database
PublishedMay 15, 2023
First seenMay 15, 2023

How to fix

Update
  • vmware greenplum_database6.22.3 or later

Affected products

ProductAffected versionsFixed in
vmware greenplum_databasev < 6.22.36.22.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.