CVE-2023-31142

Low

Description

Discourse is an open source discussion platform. Prior to version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches, if a site has modified their general category permissions, they could be set back to the default. This issue is patched in version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches. A workaround, only if you are modifying the general category permissions, is to use a new category for the same purpose.

SeverityLow
CVSS2.0
Exploit probability—
ProductDiscourse
PublishedJun 13, 2023
First seenJun 13, 2023
Weakness typeCWE-732CWE-732

How to fix

Update
  • discourse discourse3.0.4 or later

Affected products

ProductAffected versionsFixed in
discourse discoursev < 3.0.4, 3.1.03.0.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.