CVE-2023-31469
High
Description
A REST interface in Apache StreamPipes (versions 0.69.0 to 0.91.0) was not properly restricted to admin-only access. This allowed a non-admin user with valid login credentials to elevate privileges beyond the initially assigned roles. The issue is resolved by upgrading to StreamPipes 0.92.0.
SeverityHigh
CVSS8.8
Exploit probability—
Product
Apache Streampipes
PublishedJun 23, 2023
First seenJun 23, 2023
Weakness typeCWE-269Improper privilege management
How to fix
Update
- org.apache.streampipes:streampipes-parent0.92.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache streampipes | 0.69.0 ≤ v ≤ 0.91.0 | — |
| org.apache.streampipes:streampipes-parentMaven | 0.69.0 ≤ v < 0.92.0 | 0.92.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.