CVE-2023-32061

Medium

Description

Discourse is an open source discussion platform. Prior to version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches, the lack of restrictions on the iFrame tag makes it easy for an attacker to exploit the vulnerability and hide subsequent comments from other users. This issue is patched in version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches. There are no known workarounds.

SeverityMedium
CVSS5.4
Exploit probability—
ProductDiscourse
PublishedJun 13, 2023
First seenJun 13, 2023

How to fix

Update
  • discourse discourse3.0.4 or later

Affected products

ProductAffected versionsFixed in
discourse discoursev < 3.0.4, 3.1.03.0.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.