CVE-2023-32070
Critical
Description
XWiki Platform is a generic wiki platform. Prior to version 14.6-rc-1, HTML rendering didn't check for dangerous attributes/attribute values. This allowed cross-site scripting (XSS) attacks via attributes and link URLs, e.g., supported in XWiki syntax. This has been patched in XWiki 14.6-rc-1. There are no known workarounds apart from upgrading to a fixed version.
SeverityCritical
CVSS9.0
Exploit probability—
Product
Xwiki Rendering
PublishedMay 10, 2023
First seenMay 10, 2023
Weakness typeCWE-83CWE-83
How to fix
Update
- org.xwiki.rendering:xwiki-rendering-syntax-xhtml14.6-rc-1 or later
- org.xwiki.rendering:xwiki-rendering-syntax-html14.6-rc-1 or later
- org.xwiki.rendering:xwiki-rendering-syntax-html514.6-rc-1 or later
- org.xwiki.rendering:xwiki-rendering-syntax-annotatedxhtml14.6-rc-1 or later
- org.xwiki.rendering:xwiki-rendering-syntax-annotatedhtml514.6-rc-1 or later
- org.xwiki.platform:xwiki-platform-annotation-core14.6-rc-1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| xwiki rendering | 3.0 | — |
| xwiki xwiki | v ≤ 14.5 | — |
| org.xwiki.rendering:xwiki-rendering-syntax-xhtmlMaven | v < 14.6-rc-1 | 14.6-rc-1 |
| org.xwiki.platform:xwiki-core-rendering-apiMaven | v ≤ 3.0-milestone-2 | — |
| org.xwiki.rendering:xwiki-rendering-syntax-htmlMaven | v < 14.6-rc-1 | 14.6-rc-1 |
| org.xwiki.rendering:xwiki-rendering-syntax-html5Maven | v < 14.6-rc-1 | 14.6-rc-1 |
| org.xwiki.rendering:xwiki-rendering-syntax-annotatedxhtmlMaven | v < 14.6-rc-1 | 14.6-rc-1 |
| org.xwiki.rendering:xwiki-rendering-syntax-annotatedhtml5Maven | v < 14.6-rc-1 | 14.6-rc-1 |
| org.xwiki.platform:xwiki-platform-annotation-coreMaven | v < 14.6-rc-1 | 14.6-rc-1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.