CVE-2023-32314
Description
vm2 is a sandbox that can run untrusted code with Node's built-in modules. A sandbox escape vulnerability exists in vm2 for versions up to and including 3.9.17. It abuses an unexpected creation of a host object based on the specification of `Proxy`. As a result a threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version `3.9.18` of `vm2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.
How to fix
- vm2_project vm23.9.18 or later
- vm23.9.18 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vm2_project vm2 | v < 3.9.18 | 3.9.18 |
| vm2npm | v < 3.9.18 | 3.9.18 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.