CVE-2023-32315

HighActively exploited (CISA KEV)

Description

Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.

SeverityHigh
CVSS8.6
Exploit probability—
ProductIgnite Realtime Openfire
PublishedMay 26, 2023
First seenMay 26, 2023
Added to KEVAug 24, 2023

How to fix

CISA required action

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

CISA due date: Sep 14, 2023
Update
  • igniterealtime openfire4.6.8, 4.7.5 or later
  • org.igniterealtime.openfire:xmppserver4.6.8, 4.7.5 or later

Affected products

ProductAffected versionsFixed in
igniterealtime openfire3.10.0 ≤ v < 4.6.8, 4.7.0 ≤ v < 4.7.54.6.8, 4.7.5
org.igniterealtime.openfire:xmppserverMaven3.10.0 ≤ v < 4.6.8, 4.7.0 ≤ v < 4.7.54.6.8, 4.7.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.