CVE-2023-32692

Critical

Description

CodeIgniter is a PHP full-stack web framework. This vulnerability allows attackers to execute arbitrary code when you use Validation Placeholders. The vulnerability exists in the Validation library, and validation methods in the controller and in-model validation are also vulnerable because they use the Validation library internally. This issue is patched in version 4.3.5.

SeverityCritical
CVSS9.8
Exploit probability—
ProductCodeigniter
PublishedMay 30, 2023
First seenMay 30, 2023

How to fix

Update
  • codeigniter codeigniter4.3.5 or later
  • codeigniter4/framework4.3.5 or later

Affected products

ProductAffected versionsFixed in
codeigniter codeigniterv < 4.3.54.3.5
codeigniter4/frameworkPackagistv < 4.3.54.3.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.