CVE-2023-32693

High

Description

Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The external link feature is susceptible to cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in versions 0.27.3 and 0.26.7.

SeverityHigh
CVSS8.1
Exploit probability—
ProductDecidim
PublishedJul 11, 2023
First seenJul 11, 2023

How to fix

Update
  • decidim decidim0.26.7, 0.27.3 or later

Affected products

ProductAffected versionsFixed in
decidim decidimv < 0.26.7, 0.27.0 ≤ v < 0.27.30.26.7, 0.27.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.