CVE-2023-33191
Medium
Description
Kyverno is a policy engine designed for Kubernetes. Kyverno seccomp control can be circumvented. Users of the podSecurity `validate.podSecurity` subrule in Kyverno 1.9.2 and 1.9.3 are vulnerable. This issue was patched in version 1.9.4.
SeverityMedium
CVSS4.6
Exploit probability—
ProductNirmata Kyverno
PublishedMay 30, 2023
First seenMay 30, 2023
Weakness typeCWE-284Improper access control
How to fix
Update
- nirmata kyverno1.9.4 or later
- github.com/kyverno/kyverno1.9.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nirmata kyverno | 1.9.2 ≤ v < 1.9.4 | 1.9.4 |
| github.com/kyverno/kyvernoGo | 1.9.2 ≤ v < 1.9.4 | 1.9.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.