CVE-2023-33246

CriticalActively exploited (CISA KEV)

Description

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache RocketMQ
PublishedMay 24, 2023
First seenMay 24, 2023
Added to KEVSep 6, 2023

How to fix

CISA required action

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

CISA due date: Sep 27, 2023
Update
  • apache rocketmq4.9.6, 5.1.1 or later
  • org.apache.rocketmq:rocketmq-broker5.1.1 or later
  • org.apache.rocketmq:rocketmq-namesrv4.9.6, 5.1.1 or later
  • org.apache.rocketmq:rocketmq-controller5.1.1 or later

Affected products

ProductAffected versionsFixed in
apache rocketmqv < 4.9.6, 5.0.0 ≤ v < 5.1.14.9.6, 5.1.1
org.apache.rocketmq:rocketmq-brokerMaven5.0.0 ≤ v < 5.1.15.1.1
org.apache.rocketmq:rocketmq-namesrvMaven4.0.0 ≤ v < 4.9.6, 5.0.0 ≤ v < 5.1.14.9.6, 5.1.1
org.apache.rocketmq:rocketmq-controllerMaven5.0.0 ≤ v < 5.1.15.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.