CVE-2023-33725

Medium

Description

Broadleaf 5.x and 6.x (including 5.2.25-GA and 6.2.6-GA) was discovered to contain a cross-site scripting (XSS) vulnerability via a customer signup with a crafted email address. This is fixed in 6.2.6.1-GA.

SeverityMedium
CVSS6.1
Exploit probability—
ProductBroadleafcommerce Broadleaf Commerce
PublishedJun 21, 2023
First seenJun 21, 2023

How to fix

Update
  • broadleafcommerce broadleaf_commerce6.2.6.1-ga or later
  • org.broadleafcommerce:broadleaf6.2.7-GA or later

Affected products

ProductAffected versionsFixed in
broadleafcommerce broadleaf_commerce5.0 ≤ v ≤ 5.2.25-ga, 6.0 ≤ v < 6.2.6.1-ga6.2.6.1-ga
org.broadleafcommerce:broadleafMaven5.0.0-GA ≤ v < 6.2.7-GA6.2.7-GA

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.