CVE-2023-34089
Description
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The processes filter feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in version 0.27.3 and 0.26.7.
How to fix
- decidim decidim0.26.7, 0.27.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| decidim decidim | v < 0.26.7, 0.27.0 ≤ v < 0.27.3 | 0.26.7, 0.27.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.