CVE-2023-34110

Low

Description

Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.

SeverityLow
CVSS2.7
Exploit probability—
ProductFlask-appbuilder
PublishedJun 22, 2023
First seenJun 22, 2023
Weakness typeCWE-209CWE-209

How to fix

Update
  • flask-appbuilder_project flask-appbuilder4.3.2 or later
  • flask-appbuilder4.3.2 or later

Affected products

ProductAffected versionsFixed in
flask-appbuilder_project flask-appbuilderv < 4.3.24.3.2
flask-appbuilderPyPIv < 4.3.24.3.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.