CVE-2023-34396

Medium

Description

Allocation of Resources Without Limits or Throttling vulnerability in Apache Software Foundation Apache Struts.This issue affects Apache Struts: through 2.5.30, through 6.1.2. Upgrade to Struts 2.5.31 or 6.1.2.1 or greater

SeverityMedium
CVSS4.3
Exploit probability—
ProductApache Struts
PublishedJun 14, 2023
First seenJun 14, 2023

How to fix

Update
  • apache struts2.5.31, 6.1.2.1 or later
  • org.apache.struts:struts2-core2.5.31, 6.1.2.1 or later

Affected products

ProductAffected versionsFixed in
apache strutsv < 2.5.31, 6.0.0 ≤ v < 6.1.2.12.5.31, 6.1.2.1
org.apache.struts:struts2-coreMavenv < 2.5.31, 6.0.0 ≤ v < 6.1.2.12.5.31, 6.1.2.1
org.apache.struts:struts-coreMavenv ≤ 1.3.10—
struts:strutsMavenv ≤ 1.2.9—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.