CVE-2023-34442

Low

Description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Software Foundation Apache Camel.This issue affects Apache Camel: from 3.X through <=3.14.8, from 3.18.X through <=3.18.7, from 3.20.X through <= 3.20.5, from 4.X through <= 4.0.0-M3. Users should upgrade to 3.14.9, 3.18.8, 3.20.6 or 3.21.0 and for users on Camel 4.x update to 4.0.0-M1

SeverityLow
CVSS3.3
Exploit probability—
ProductApache Camel
PublishedJul 10, 2023
First seenJul 10, 2023

How to fix

Update
  • apache camel3.14.9, 3.18.8, 3.20.6 or later
  • org.apache.camel:camel-jira3.14.9, 3.18.8, 3.20.6, 4.0.0-RC1 or later

Affected products

ProductAffected versionsFixed in
apache camel3.0.0 ≤ v < 3.14.9, 3.18.0 ≤ v < 3.18.8, 3.20.0 ≤ v < 3.20.6, 4.0.03.14.9, 3.18.8, 3.20.6
org.apache.camel:camel-jiraMaven3.0.0-M3 ≤ v < 3.14.9, 3.15.0 ≤ v < 3.18.8, 3.20.0 ≤ v < 3.20.6, 4.0.0-M1 ≤ v < 4.0.0-RC13.14.9, 3.18.8, 3.20.6, 4.0.0-RC1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.