CVE-2023-34459

Medium

Description

OpenZeppelin Contracts is a library for smart contract development. Starting in version 4.7.0 and prior to version 4.9.2, when the `verifyMultiProof`, `verifyMultiProofCalldata`, `procesprocessMultiProof`, or `processMultiProofCalldat` functions are in use, it is possible to construct merkle trees that allow forging a valid multiproof for an arbitrary set of leaves. A contract may be vulnerable if it uses multiproofs for verification and the merkle tree that is processed includes a node with value 0 at depth 1 (just under the root). This could happen inadvertedly for balanced trees with 3 leaves or less, if the leaves are not hashed. This could happen deliberately if a malicious tree builder includes such a node in the tree. A contract is not vulnerable if it uses single-leaf proving (`verify`, `verifyCalldata`, `processProof`, or `processProofCalldata`), or if it uses multiproofs with a known tree that has hashed leaves. Standard merkle trees produced or validated with the @openzeppelin/merkle-tree library are safe. The problem has been patched in version 4.9.2. Some workarounds are available. For those using multiproofs: When constructing merkle trees hash the leaves and do not insert empty nodes in your trees. Using the @openzeppelin/merkle-tree package eliminates this issue. Do not accept user-provided merkle roots without reconstructing at least the first level of the tree. Verify the merkle tree structure by reconstructing it from the leaves.

SeverityMedium
CVSS5.3
Exploit probability—
ProductOpenzeppelin Contracts
PublishedJun 16, 2023
First seenJun 16, 2023
Weakness typeCWE-354CWE-354

How to fix

Update
  • openzeppelin contracts4.9.2 or later
  • openzeppelin contracts_upgradeable4.9.2 or later
  • @openzeppelin/contracts4.9.2 or later
  • @openzeppelin/contracts-upgradeable4.9.2 or later

Affected products

ProductAffected versionsFixed in
openzeppelin contracts4.7.0 ≤ v < 4.9.24.9.2
openzeppelin contracts_upgradeable4.7.0 ≤ v < 4.9.24.9.2
@openzeppelin/contractsnpm4.7.0 ≤ v < 4.9.24.9.2
@openzeppelin/contracts-upgradeablenpm4.7.0 ≤ v < 4.9.24.9.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-34459 · Openzeppelin Contracts · Dark Radar