CVE-2023-35005

Medium

Description

In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations. This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if `[webserver] expose_config` is set to `non-sensitive-only`), and not all uncensored values are actually sentitive. This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Airflow
PublishedJun 19, 2023
First seenJun 19, 2023

How to fix

Update
  • apache airflow2.6.2 or later
  • apache-airflow2.6.2rc1, 2.6.2 or later

Affected products

ProductAffected versionsFixed in
apache airflow2.5.0 ≤ v < 2.6.22.6.2
apache-airflowPyPI2.5.0 ≤ v < 2.6.2rc1, 2.5.0 ≤ v < 2.6.22.6.2rc1, 2.6.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-35005 · Apache Airflow · Dark Radar