CVE-2023-35797

Critical

Description

Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Hive Provider. This issue affects Apache Airflow Apache Hive Provider: before 6.1.1. Before version 6.1.1 it was possible to bypass the security check to RCE via principal parameter. For this to be exploited it requires access to modifying the connection details. It is recommended updating provider version to 6.1.1 in order to avoid this vulnerability.

SeverityCritical
CVSS9.8
Exploit probability86. percentile2.8%
ProductApache-airflow-providers-apache-hive
PublishedJul 3, 2023
First seenJul 3, 2023

How to fix

Update
  • apache apache-airflow-providers-apache-hive6.1.1 or later
  • apache-airflow-providers-apache-hive6.1.1 or later

Affected products

ProductAffected versionsFixed in
apache apache-airflow-providers-apache-hivev < 6.1.16.1.1
apache-airflow-providers-apache-hivePyPIv < 6.1.16.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.