CVE-2023-36827

High

Description

Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. A path traversal (directory traversal) vulnerability affects fides versions lower than version `2.15.1`, allowing remote attackers to access arbitrary files on the fides webserver container's filesystem. The vulnerability is patched in fides `2.15.1`. If the Fides webserver API is not directly accessible to attackers and is instead deployed behind a reverse proxy as recommended in Ethyca's security best practice documentation, and the reverse proxy is an AWS application load balancer, the vulnerability can't be exploited by these attackers. An AWS application load balancer will reject this attack with a 400 error. Additionally, any secrets supplied to the container using environment variables rather than a `fides.toml` configuration file are not affected by this vulnerability.

SeverityHigh
CVSS7.5
Exploit probability—
ProductEthyca Fides
PublishedJul 5, 2023
First seenJul 5, 2023

How to fix

Update
  • ethyca fides2.15.1 or later
  • ethyca-fides2.15.1 or later

Affected products

ProductAffected versionsFixed in
ethyca fidesv < 2.15.12.15.1
ethyca-fidesPyPIv < 2.15.12.15.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.