CVE-2023-3714

High

Description

The ProfileGrid plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'edit_group' handler in versions up to, and including, 5.5.2. This makes it possible for authenticated attackers, with group ownership, to update group options, including the 'associate_role' parameter, which defines the member's role. This issue was partially patched in version 5.5.2 preventing privilege escalation, however, it was fully patched in 5.5.3.

SeverityHigh
CVSS7.5
Exploit probability—
ProductMetagauss Profilegrid
PublishedJul 18, 2023
First seenJul 18, 2023

How to fix

Update
  • metagauss profilegrid5.5.3 or later

Affected products

ProductAffected versionsFixed in
metagauss profilegridv < 5.5.35.5.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.