CVE-2023-37478

High

Description

pnpm is a package manager. It is possible to construct a tarball that, when installed via npm or parsed by the registry is safe, but when installed via pnpm is malicious, due to how pnpm parses tar archives. This can result in a package that appears safe on the npm registry or when installed via npm being replaced with a compromised or malicious version when installed via pnpm. This issue has been patched in version(s) 7.33.4 and 8.6.8.

SeverityHigh
CVSS7.5
Exploit probability—
ProductPnpm
PublishedAug 1, 2023
First seenAug 1, 2023

How to fix

Update
  • pnpm pnpm7.33.4, 8.6.8 or later
  • pnpm7.33.4, 8.6.8 or later
  • @pnpm/exe7.33.4, 8.6.8 or later
  • @pnpm/linux-arm647.33.4, 8.6.8 or later
  • @pnpm/linux-x647.33.4, 8.6.8 or later
  • @pnpm/linuxstatic-arm647.33.4, 8.6.8 or later
  • @pnpm/macos-arm647.33.4, 8.6.8 or later
  • @pnpm/macos-x647.33.4, 8.6.8 or later
  • @pnpm/win-x647.33.4, 8.6.8 or later
  • @pnpm/cafs7.0.5 or later

Affected products

ProductAffected versionsFixed in
pnpm pnpmv < 7.33.4, 8.0.0 ≤ v < 8.6.87.33.4, 8.6.8
pnpmnpmv < 7.33.4, 8.0.0 ≤ v < 8.6.87.33.4, 8.6.8
@pnpm/exenpmv < 7.33.4, 8.0.0 ≤ v < 8.6.87.33.4, 8.6.8
@pnpm/linux-arm64npmv < 7.33.4, 8.0.0 ≤ v < 8.6.87.33.4, 8.6.8
@pnpm/linux-x64npmv < 7.33.4, 8.0.0 ≤ v < 8.6.87.33.4, 8.6.8
@pnpm/linuxstatic-arm64npmv < 7.33.4, 8.0.0 ≤ v < 8.6.87.33.4, 8.6.8
@pnpm/macos-arm64npmv < 7.33.4, 8.0.0 ≤ v < 8.6.87.33.4, 8.6.8
@pnpm/macos-x64npmv < 7.33.4, 8.0.0 ≤ v < 8.6.87.33.4, 8.6.8
@pnpm/win-x64npmv < 7.33.4, 8.0.0 ≤ v < 8.6.87.33.4, 8.6.8
@pnpm/cafsnpmv < 7.0.57.0.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-37478 · Pnpm · Dark Radar