CVE-2023-37544

High

Description

Improper Authentication vulnerability in Apache Pulsar WebSocket Proxy allows an attacker to connect to the /pingpong endpoint without authentication. This issue affects Apache Pulsar WebSocket Proxy: from 2.8.0 through 2.8.*, from 2.9.0 through 2.9.*, from 2.10.0 through 2.10.4, from 2.11.0 through 2.11.1, 3.0.0. The known risks include a denial of service due to the WebSocket Proxy accepting any connections, and excessive data transfer due to misuse of the WebSocket ping/pong feature. 2.10 Pulsar WebSocket Proxy users should upgrade to at least 2.10.5. 2.11 Pulsar WebSocket Proxy users should upgrade to at least 2.11.2. 3.0 Pulsar WebSocket Proxy users should upgrade to at least 3.0.1. 3.1 Pulsar WebSocket Proxy users are unaffected. Any users running the Pulsar WebSocket Proxy for 2.8, 2.9, and earlier should upgrade to one of the above patched versions.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Pulsar
PublishedDec 20, 2023
First seenDec 20, 2023

How to fix

Update
  • apache pulsar2.10.5, 2.11.2 or later
  • org.apache.pulsar:pulsar-websocket2.10.5, 2.11.2, 3.0.1 or later

Affected products

ProductAffected versionsFixed in
apache pulsarv < 2.10.5, 2.11.0 ≤ v < 2.11.2, 3.0.02.10.5, 2.11.2
org.apache.pulsar:pulsar-websocketMavenv < 2.10.5, 2.11.0 ≤ v < 2.11.2, 3.0.0 ≤ v < 3.0.12.10.5, 2.11.2, 3.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.