CVE-2023-37582
Description
The RocketMQ NameServer component still has a remote command execution vulnerability as the CVE-2023-33246 issue was not completely fixed in version 5.1.1. When NameServer address are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function on the NameServer component to execute commands as the system users that RocketMQ is running as. It is recommended for users to upgrade their NameServer version to 5.1.2 or above for RocketMQ 5.x or 4.9.7 or above for RocketMQ 4.x to prevent these attacks.
How to fix
- org.apache.rocketmq:rocketmq-namesrv4.9.7, 5.1.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache rocketmq | v ≤ 4.9.6, 5.0.0 ≤ v ≤ 5.1.1 | — |
| org.apache.rocketmq:rocketmq-namesrvMaven | v < 4.9.7, 5.0.0 ≤ v < 5.1.2 | 4.9.7, 5.1.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.