CVE-2023-37918
Description
Dapr is a portable, event-driven, runtime for building distributed applications across cloud and edge. A vulnerability has been found in Dapr that allows bypassing API token authentication, which is used by the Dapr sidecar to authenticate calls coming from the application, with a well-crafted HTTP request. Users who leverage API token authentication are encouraged to upgrade Dapr to 1.10.9 or to 1.11.2. This vulnerability impacts Dapr users who have configured API token authentication. An attacker could craft a request that is always allowed by the Dapr sidecar over HTTP, even if the `dapr-api-token` in the request is invalid or missing. The issue has been fixed in Dapr 1.10.9 or to 1.11.2. There are no known workarounds for this vulnerability.
How to fix
- linuxfoundation dapr1.10.9, 1.11.2 or later
- github.com/dapr/dapr1.11.2, 1.10.9 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| linuxfoundation dapr | v < 1.10.9, 1.11.0 ≤ v < 1.11.2 | 1.10.9, 1.11.2 |
| github.com/dapr/daprGo | 1.11.0 ≤ v < 1.11.2, v < 1.10.9 | 1.11.2, 1.10.9 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.