CVE-2023-37924

Critical

Description

Apache Software Foundation Apache Submarine has an SQL injection vulnerability when a user logs in. This issue can result in unauthorized login. Now we have fixed this issue and now user must have the correct login to access workbench. This issue affects Apache Submarine: from 0.7.0 before 0.8.0. We recommend that all submarine users with 0.7.0 upgrade to 0.8.0, which not only fixes the issue, supports the oidc authentication mode, but also removes the case of unauthenticated logins. If using the version lower than 0.8.0 and not want to upgrade, you can try cherry-pick PR https://github.com/apache/submarine/pull/1037 https://github.com/apache/submarine/pull/1054 and rebuild the submarine-server image to fix this.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Submarine
PublishedNov 22, 2023
First seenNov 22, 2023
Weakness typeCWE-89SQL injection

How to fix

Update
  • apache submarine0.8.0 or later
  • apache-submarine0.8.0 or later

Affected products

ProductAffected versionsFixed in
apache submarine0.7.0 ≤ v < 0.8.00.8.0
apache-submarinePyPI0.7.0 ≤ v < 0.8.00.8.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.