CVE-2023-38492

Medium

Description

Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 affects all Kirby sites with user accounts (unless Kirby's API and Panel are disabled in the config). The real-world impact of this vulnerability is limited, however we still recommend to update to one of the patch releases because they also fix more severe vulnerabilities. Kirby's authentication endpoint did not limit the password length. This allowed attackers to provide a password with a length up to the server's maximum request body length. Validating that password against the user's actual password requires hashing the provided password, which requires more CPU and memory resources (and therefore processing time) the longer the provided password gets. This could be abused by an attacker to cause the website to become unresponsive or unavailable. Because Kirby comes with a built-in brute force protection, the impact of this vulnerability is limited to 10 failed logins from each IP address and 10 failed logins for each existing user per hour. The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have added password length limits in the affected code so that passwords longer than 1000 bytes are immediately blocked, both when setting a password and when logging in.

SeverityMedium
CVSS5.3
Exploit probability—
ProductKirby
PublishedJul 27, 2023
First seenJul 27, 2023

How to fix

Update
  • getkirby kirby3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, 3.9.6 or later
  • getkirby/cms3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, 3.9.6 or later

Affected products

ProductAffected versionsFixed in
getkirby kirby3.5.0 ≤ v < 3.5.8.3, 3.6.0 ≤ v < 3.6.6.3, 3.7.0 ≤ v < 3.7.5.2, 3.8.0 ≤ v < 3.8.4.1, 3.9.0 ≤ v < 3.9.63.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, 3.9.6
getkirby/cmsPackagistv < 3.5.8.3, 3.6.0 ≤ v < 3.6.6.3, 3.7.0 ≤ v < 3.7.5.2, 3.8.0 ≤ v < 3.8.4.1, 3.9.0 ≤ v < 3.9.63.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, 3.9.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.