CVE-2023-38510

High

Description

Tolgee is an open-source localization platform. Starting in version 3.14.0 and prior to version 3.23.1, when a request is made using an API key, the backend fails to verify the permission scopes associated with the key, effectively bypassing permission checks entirely for some endpoints. It's important to note that this vulnerability only affects projects that have inadvertently exposed their API keys on the internet. Projects that have kept their API keys secure are not impacted. This issue is fixed in version 3.23.1.

SeverityHigh
CVSS8.1
Exploit probability49. percentile0.6%
ProductTolgee
PublishedJul 27, 2023
First seenJul 27, 2023

How to fix

Update
  • tolgee tolgee3.23.1 or later

Affected products

ProductAffected versionsFixed in
tolgee tolgee3.14.0 ≤ v < 3.23.13.23.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.