CVE-2023-38522

High

Description

Apache Traffic Server accepts characters that are not allowed for HTTP field names and forwards malformed requests to origin servers. This can be utilized for request smuggling and may also lead cache poisoning if the origin servers are vulnerable. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.10, from 9.0.0 through 9.2.4. Users are recommended to upgrade to version 8.1.11 or 9.2.5, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Traffic Server
PublishedJul 26, 2024
First seenJul 26, 2024
Weakness typeCWE-444CWE-444

How to fix

Update
  • apache traffic_server8.1.11, 9.2.5 or later

Affected products

ProductAffected versionsFixed in
apache traffic_server8.0.0 ≤ v < 8.1.11, 9.0.0 ≤ v < 9.2.58.1.11, 9.2.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-38522 · Apache Traffic Server · Dark Radar