CVE-2023-38646

Critical

Description

Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow attackers to execute arbitrary commands on the server, at the server's privilege level. Authentication is not required for exploitation. The other fixed versions are 0.45.4.1, 1.45.4.1, 0.44.7.1, 1.44.7.1, 0.43.7.2, and 1.43.7.2.

SeverityCritical
CVSS9.8
Exploit probability—
ProductMetabase
PublishedJul 21, 2023
First seenJul 21, 2023

How to fix

Update
  • metabase metabase0.43.7.2, 1.43.7.2, 0.44.7.1, 0.45.4.1, 0.46.6.1, 1.44.7.1, 1.45.4.1, 1.46.6.1 or later

Affected products

ProductAffected versionsFixed in
metabase metabasev < 0.43.7.2, v < 1.43.7.2, 0.44.0 ≤ v < 0.44.7.1, 0.45.0 ≤ v < 0.45.4.1, 0.46.0 ≤ v < 0.46.6.1, 1.44.0 ≤ v < 1.44.7.1, 1.45.0 ≤ v < 1.45.4.1, 1.46.0 ≤ v < 1.46.6.10.43.7.2, 1.43.7.2, 0.44.7.1, 0.45.4.1, 0.46.6.1, 1.44.7.1, 1.45.4.1, 1.46.6.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.